Dragon Age 2 patch - now I can't play -__- [SOLVED]

View previous topic View next topic Go down

Dragon Age 2 patch - now I can't play -__- [SOLVED]

Post by Cellitha on Wed 10 Apr 2013, 17:26

Hi everyone!

Since I can't play sims 3 anymore (got stuck e few weeks ago and haven't gotten any help yet) I started playing Dragon Age. Again.
So I played thru Dragon Age: Origins, which I bought several years ago, but then started on Dragon Age 2, which I downloaded.
It's all worked fine, even all the DLC has worked excellent, until I started to get an annoying bug where the computer blacks out on me.
"I should get the latest patch" thought I. Downloaded it, installed it and - now I can't play. Because they suddenly want me to register and I don't have a valid product key.
Figures; I should have thought something like this could happen, but the game wanted me to register before and then I've simply been able to click "Close" and not be bothered.

How do I get a valid key? Or can I uninstall the patch? How?


Okey, fixed it - got this one
( )
and now all works fine again! ^_^
Posting Nerd
Posting Nerd

Windows version :
  • Windows 7

Favourite games : Right now: Dragon Age: Inquisition and Assassin's Creed: Black Flag!


Posts : 55
Points : 2162
Reputation : 1
Join date : 2012-12-31
Age : 34
Location : Sweden

View user profile

Back to top Go down

Re: Dragon Age 2 patch - now I can't play -__- [SOLVED]

Post by Webmaster on Fri 12 Apr 2013, 21:20

Hello there,

Glad to hear you fixed it!
Enjoy the game and please let us know if you need assistance again!

 to Games4theworld


Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)


Posts : 18909
Points : 1026808
Reputation : 2272
Join date : 2010-03-12

View user profile

Back to top Go down

View previous topic View next topic Back to top

Permissions in this forum:
You cannot reply to topics in this forum