How to fix the graphic glitch whenever you are in Map View (The Sims 2)

View previous topic View next topic Go down

How to fix the graphic glitch whenever you are in Map View (The Sims 2) Empty How to fix the graphic glitch whenever you are in Map View (The Sims 2)

Post by J.T. on Wed 12 Feb 2014, 10:37

Hello Simmers of The Sims 2!

Sometimes you will find that the coasts/valleys of several neighbourhoods in The Sims 2 are surrounded by some sort of weirdly-looking solid blue water, and in case you do not understand what I am talking about, here is a picture illustrating the issue:

How to fix the graphic glitch whenever you are in Map View (The Sims 2) CrappyNeighborhood

Yes, everyone knows it is hella annoying. So how can this be resolved? Follow the following steps to break through the problem:

(1) First of all, (again) you need to back a file up. This time, back up Graphic Rules.sgr located inside the folder of the latest expansion pack/stuff pack that you have installed on your pc (back up here means, to copy and paste the content to anywhere other than the same folder, preferably Desktop), namely C:\Program Files (x86)\EA GAMES\The Sims 2 (The newest expansion pack/stuff pack inserted here)\TSData\Res\Config\. In my pc, it is The Sims 2 Mansion and Gardening Stuff. In my case, I should back up Graphic Rules.sgr in C:\Program Files (x86)\EA GAMES\The Sims 2 Mansion and Gardening Stuff\TSData\Res\Config\.
(2) Now navigate to the same folder and right-click Graphic Rules.sgr and choose Properties. Go under "Security" tab. There, find your own username that you are loggin' in with your computer on, and click on "Edit". Make sure that the box "Full Control" is checked and save the setting.
(3) Now double-click the file (Or right-click the file and choose "Open With...", and then Notepad or Notepad++). There, you will find a lot of content, but all you need to do is to adjust some settings. Hold Ctrl + F and type "simpleterrain" (without quotes of course) and then hit enter. Change the value "true" next to "boolProp simpleTerrain" to "false".

It should be changed from something like

boolProp simpleTerrain true


boolProp simpleTerrain false

(4) We are not done yet! There are 2 more codes you need to change. Hold Ctrl + F and find the same keywords again ("simpleTerrain"), and change them all like step 3.

Now run the game and you will see the difference! Smile

Note: People with pcs with Intel HD Graphics/Intel Express Chipset Family (or something similar to that) as the graphic cards are strongly advised not to attempt this trick. This will produce unintended results (such as overheating). However, with a cheap and crappy graphic GPU (Intel GM45 Express Chipset) on my pc, I can still perform this tutorial without an obstacle or a problem. Still, bear this in mind!

Mod edit: Topic moved to "The Sims 1 & 2 & Medieval Fixes".

- Carlos
RETIRED Quartermaster Lieutenant
Discharged with Honors

RETIRED Quartermaster LieutenantDischarged with Honors

Windows version :
  • Windows 7

System architecture :
  • 32 bits (x86)


Posts : 3438
Points : 6480
Reputation : 306
Join date : 2013-01-29
Age : 23
Location : Panem

View user profile

Back to top Go down

View previous topic View next topic Back to top

Permissions in this forum:
You cannot reply to topics in this forum